Community Forums, Moderated > General Discussion

Resetting my device

(1/2) > >>

Hi Jim,

I've read your post on resetting the device.,27.msg27.html#msg27

However when trying to reset it using the defaults you provided, EtherRain Admin still complains about a value being more than 255. I guess this is because I left the primary and secondary dns entries blank.

I then tried to use for the dns entries, but it still failed on a different error. On the second attempt a few minutes later it only accepted the settings.

So I have reset my device now with DCHP on and the defaults you provided, but now that it is reset, the EtherRain Admin is not picking up the device, despite the router assigning the same ip address that it had before when I was using a fixed address.

I have left it alone/running for quite a while to see if it will find it.

(Fixed: I just switched all the LAN cables around again...) I did test the LAN cable itself and that tested 100%.

I'm not able to ping the EtherRain. Is that disabled?


Ps. For those who like all the detail...

The issue that I'm having is that my irrigation stopped working this working. I'm assuming it is network issues. Last week my one port on my wireless router blew but that I only discovered after switching my EtherRain to the blown port which meant it did not irrigate :-/

This week it is something else so just wanted to reset everything and start a new. Partly because when setting everything up initially I could not get it to work and ended up adding port forwarding and assigning manual ip addresses only to discover that for it to work your irrigation tap should be open. (Let me have it, I deserve it.) (I had a leak before the manifold so closed the tap between (manual) irrigation cycles. Now that it is automated I of course had to fix the leak.)

Anyway, as it was working I just left it as is, but now want to eliminate all the extra settings as a possible cause for my new issues.

Ok here we go again...

I decided to replace my adsl router as I need all 4 port on the router.

Now that the router is configured, I cannot get my EtherRain to work again...

Surely I'm missing something as this cannot be this difficult...

I have tried switching off the EtherRain and leaving it off for at least 10 seconds. Then switching it back on. I also tried it with the LAN cable out.

When I look in my list of DHCP client connected to the router, the EtherRain does not show up in the list. This leads me to believe that my altering to use DHCP on it did not work...

The green LAN light comes on immediately or when the power comes on/or when I connect the LAN cable.

I get the following in my router log;

Feb 27 11:11:03   user   crit   kernel: eth2 Link DOWN.
Feb 27 11:11:03   user   info   kernel: br0: port 3(eth2) entering disabled state
Feb 27 11:11:08   user   crit   kernel: eth2 Link UP 10 mbps half duplex
Feb 27 11:11:08   user   info   kernel: br0: port 3(eth2) entering forwarding state
Feb 27 11:11:16   user   crit   kernel: eth2 Link DOWN.
Feb 27 11:11:16   user   info   kernel: br0: port 3(eth2) entering disabled state

I'm assuming eth2 is port 3 where the EtherRain is plugged in.

Any help on what else to try?

I'm now going to plug it directly into my PC to see if the java admin client can't detect it.



I tried to connect my EtherRain directly to my MacBook Pro but it showed the same behaviour as the log above. It would get the fixed IP address and then drop the connection. I'm assuming either my MBP or the EtherRain would be able to turn my cable into a cross-over cable.

Then I took my Raspberry Pi and connected it in place of the EtherRain. It came up with an IP address immediately.

Then I connected the EtherRain back to the old router and try to discover it, but the java Admin app could not find it.

Does the EtherRain want/expect internet before it will start to work? My old router is not longer connected to the ADSL, which means the java app won't launch. I found before that you have to kill it and restart it before it picks up the device.

Anyway, I guess I have no choice but to perform a hard reset. I wasn't looking forward to it as it is stuck with double sided tape so will be messy...

Ok some more info...

I reconnected it back to the old router and this time the EtherRain got assigned an IP address, meaning it is following DHCP. However, the javaAdmin client could not detect it and I could also not restart it as the old router is no longer connected to the internet. I did not check the mac address but am pretty sure that was the EtherRain that was connected to the router.

I left the EtherRain disconnected overnight and then powered it up connected to the new router this morning. It again does not want to get an IP address and keeps on throwing the messages in the log as before.

So my conclusion is that there is something this router does differently. It is a D-Link DSL2750-U running the firmware version AF_1.72_R01.

Everything else in the house works normally, it is only the EtherRain that is not getting an IP address. I have also tried more than one port on the router.

Are there anything else I can try/set/test? According to me I tested the cable and cable tests ok, I tested the port and the port tested ok, I can get an ip assigned to a device connected on that port, using that cable. And I can get the EtherRain to get an IP address using the old router. So all the bits and pieces are in working order. It is just not talking to each other.

Any help would be appreciated.



Ok I tried a brand new Netgear router and it is also acting the same. I can also no longer get the original router to work.

So I guess the Ethernet port on the EtherRain is blown :-/


[0] Message Index

[#] Next page

Go to full version