Recent Posts

Pages: 1 2 [3] 4 5 ... 10
Feature Requests / Re: Feature request: usage log web interface
« Last post by Jim on July 11, 2015, 08:13:35 pm »
Hello Steve,

We definitely want to do a better job with the logs and adding the program name is a priority (July 2015).  We've done this in OptiRain Open and want to move that code into LawnCheck.

And yes we want to do a better job with graphical schedules and have some ideas on implementing a graphical schedule.

Thanks for the request.


Feature Requests / Re: Adding a Notepad to keep details of each zone
« Last post by Jim on July 11, 2015, 08:10:13 pm »
Hello Gangee,

It's a good idea and is possible.  We've just implemented the sequential linking (which was quite complicated ordeal, though it now works) and will do a slight rebrand before thinking about additional features.

Thank you for the request.


Feature Requests / Re: two pause features
« Last post by Jim on July 11, 2015, 08:07:38 pm »
Hello Steve,

Currently with LawnCheck you must pause every program.  I guess if you have multiple controllers this might get tedious hence the call for a global pause.  We haven't thought of the global pause and will have to think through it.

If you have multiple controllers we now have sequential linking allowing you to create 16 and 24 zone programs.  In this case, if you linked, you'd only have to pause the starting program.

Thanks for your request.

Feature Requests / Re: Hostname on device
« Last post by Jim on July 11, 2015, 08:03:10 pm »
Hello Paul,
Sorry for the late reply.  Not sure what you mean by hostname.  LawnCheck only uses the controller name and your account number. 

To get the IP address for the controller, use EtherRain Admin.

Hope this helps.

Feature Requests / Re: "chain" two devices together
« Last post by Jim on July 11, 2015, 08:00:30 pm »
Hello Paul,

Yes, its July 10 2015 and "chaining" has been implemented.  You must have two or more controllers within your account.  Chaining is called Sequential Linking and has been tested for up to three controllers.  It should work for more than three if you have them, but over three hasn't been tested.   Multicycle has been tested to an extent.

Because this is relatively new you should check your logs.   Standard linking (ie, non-multicyle) has been tested for about 3 months now under various conditions.  It appears to work well with no overlap - each program in the "chain" starts about 1 to 3 minutes after the last program has completed.   Sequential linking works only for scheduled programs not for manual/quick cycles.

After you have linked programs together you will find that it is very easy to click through the chain using the links on the program summary screen starting with the starting program.

Here's the  help page for sequential linking.

Feature Requests / Re: "chain" two devices together
« Last post by pohoda on June 24, 2015, 09:09:19 am »
Hi Jim,

Has there been any progress on getting the chaining done for I see that you have completed the Android app and I am using it.


General Discussion / Re: Resetting my device
« Last post by PollieXmas on March 11, 2015, 05:13:52 am »
I managed to reset the device using the supplied jumper, but this also did not help.

Essentially I see the same behaviour on the Ethernet port of the device itself as what I'm seeing on the router. The green LED on the Ethernet port will light up. The Yellow will flicker randomly and then both lights go off. Only to start the sequence again 2 seconds later.

Has anybody seen this behaviour and what it could possibly be?

Then, are there other recommendations on how to build one that can be serviced locally as in this case?
General Discussion / Re: Resetting my device
« Last post by PollieXmas on March 05, 2015, 11:35:50 am »
Ok I tried a brand new Netgear router and it is also acting the same. I can also no longer get the original router to work.

So I guess the Ethernet port on the EtherRain is blown :-/
General Discussion / Re: Resetting my device
« Last post by PollieXmas on March 01, 2015, 12:12:09 am »
Ok some more info...

I reconnected it back to the old router and this time the EtherRain got assigned an IP address, meaning it is following DHCP. However, the javaAdmin client could not detect it and I could also not restart it as the old router is no longer connected to the internet. I did not check the mac address but am pretty sure that was the EtherRain that was connected to the router.

I left the EtherRain disconnected overnight and then powered it up connected to the new router this morning. It again does not want to get an IP address and keeps on throwing the messages in the log as before.

So my conclusion is that there is something this router does differently. It is a D-Link DSL2750-U running the firmware version AF_1.72_R01.

Everything else in the house works normally, it is only the EtherRain that is not getting an IP address. I have also tried more than one port on the router.

Are there anything else I can try/set/test? According to me I tested the cable and cable tests ok, I tested the port and the port tested ok, I can get an ip assigned to a device connected on that port, using that cable. And I can get the EtherRain to get an IP address using the old router. So all the bits and pieces are in working order. It is just not talking to each other.

Any help would be appreciated.


General Discussion / Re: Resetting my device
« Last post by PollieXmas on February 27, 2015, 10:08:37 pm »
I tried to connect my EtherRain directly to my MacBook Pro but it showed the same behaviour as the log above. It would get the fixed IP address and then drop the connection. I'm assuming either my MBP or the EtherRain would be able to turn my cable into a cross-over cable.

Then I took my Raspberry Pi and connected it in place of the EtherRain. It came up with an IP address immediately.

Then I connected the EtherRain back to the old router and try to discover it, but the java Admin app could not find it.

Does the EtherRain want/expect internet before it will start to work? My old router is not longer connected to the ADSL, which means the java app won't launch. I found before that you have to kill it and restart it before it picks up the device.

Anyway, I guess I have no choice but to perform a hard reset. I wasn't looking forward to it as it is stuck with double sided tape so will be messy...
Pages: 1 2 [3] 4 5 ... 10